Trading Blox System Editor area is where systems are created, changed, or removed.  A system name can be almost any name when the Naming Rules are understood.  

Click on an area for more information.

System Menus and Available System Names

 

Any system name listed in the list of available system names can be changed, removed, exported, or printed.  Access to the list of options is available when the System Menu option is clicked at the top of the System Editor, or when a system is selected and the system name list is right-clicked.

 

When a system name is selected its list of blox modules can be created, changed or some can be removed using the Blox Menu options in the System Editor.

Naming Rules:

Suite, System and Blox module names can include the following keyboard characters:

All letters letters "A - Z" and "a - z".

All numbers from "0 to 9".

The keyboard space " ", hyphen "-", and underscore "_" symbols.

 


System Editing Changes:

All system changes are temporary until the "OK" button is pressed.  Pressing the "Cancel" button after making any changes to one or many systems will allow all the changes to be lost when the System Editor is opened, or the changed system are tested after the change.

 

When a change is required, make the change and press the "OK" button.  If more changes are needed to the same file or any other system file, open the System Editor again and make the changes needed.

 

System Names:

Description:

Standard System:

A standard system is any system that does not have the same name as any suite name in the list of available suites.   A standard systems is not intended to be Global Suite System (GSS).   All standard systems are assigned a system test sequence identification number that reflects is assigned in the same the ascending sorted order its system's name (see left to right the selection tab order in multi-suystem suites).  All standard systems execute their script sections in the same order and each system's script section is executed in the incrementing sequence of its assigned system identification number.

Global System:

Any system name that matches any suite name in the list of available suite names will automatically be designated as a Global Suite System (GSS).  These system get a system number designator of zero and have special timing for some of its script sections.  GSS systems do not generate orders without special scripting methods.

 

System Menu: ^Top

Options:

Descriptions:

You can create new systems and delete systems, and change what is in a system using the system editor.  You build systems by selecting, or creating a new system name on the left, and then add Blox from the available blox list on the right.

 

Some of the lists accept multiple Blox and some lists can accept only one Block. The Portfolio Manager, the Risk Manager, and the Money Manager can accept only one Block per system.  The Entry Block, Exit and Auxiliary block names can appear more than one time in a system. The reason for this is that you may want to have multiple entry/exit ideas executing at the same time.  You might also want to have different risk, portfolio and reporting ideas operating at the same time.

 

Trading Blox System Editor menu provides the controls for creating a new system name, making a copy of an existing system name, renaming a current system, exporting a system as an encrypted system, or displaying the system modules and their active script section is controlled by selecting one of the options in this menu.

 

System Editor System Menu Options:

System Editor System Menu Options:

 

Selecting a System name in the system name list and right-clicking the mouse will display the same menu near the selected system:

System Menu Right-Click Access

System Menu Right-Click Access

New

To create a new system name, enter the new name for the new system in the text area after clicking the System's New menu:

SystemEditor-SystemNew

See: System Names

Copy

To edit or copy a system name so it be the same system logic, but have a different system name, enter the name here:

SystemEditor-SystemCopy

 

Create a copy of a selected system name so it can be given a new system name, and or be modified to work differently by changing some of the blox ideas that will be different from the selected system name.

 

See: System Names

Delete

System Editor's System Delete menu will remove the system from the software and from the computer's disk.  Deleting a system name does not delete the blox assigned to the system because blox assignments are by name reference only.

 

To delete a selected system name, click on the Delete menu and answer "Yes" or "No" to confirm or reject your action when this next dialog appears.

 

When "Yes" is clicked, the selected system will be deleted from the disk and the software even if you click on the Cancel button to exit the System Editor.  If you answer "No" to Not-Delete the system, the delete action will be aborted:

SystemEditor-SystemDelete

Notes:

If you delete a systems by mistake it can be recreated again by using the techniques you would use to create a new system.  If the system is a Trading Blox supplied system you can install a new copy of Trading Blox on your computer in a different directory location and the Suite Menu's Export and Import feature to bring back into the Trading Blox installation where it was accidentally deleted.  This may also be one of those times when you remember how good a regular back up of your disk will feel.

 

You can also use the automated Backup files to recover the deleted system if this day isn't the first day that the deleted system was in the list of system names.

Rename

This menu selection will Rename a selected system name.  Any name that is in accordance with the Naming Rules can be used.  This can be handy when you are adding or exporting a system version so it can be added to a suite more than once, but tested with different parameter value or portfolio files, or any other idea.

 

Edit or replace the system name to its new name:

SystemEditor-SystemRename

See: System Names

Export

Creates a protected export file and opens the folder where the file is saved so it can be accessed.

 

This option will Export and Encrypt the selected system name.  Exported systems are exported and placed to Export folder as a special encrypted file.  Imported encrypted system can be tested in a suite. Exported system parameters are visible and can be changed.

 

Before exporting a any system ensure the system name you are exporting is unique.  This is required because Trading Blox will not import a system name is the same as a system name in the Trading Blox installation where the file is to be imported.  When the name is the same, this message will appear:

Click to Enlarge; Click to Reduce.

Imported System Name Already Exists Error Message.

 

When a system is exported it creates a protected system using encryption:

Click to Enlarge; Click to Reduce.

System Editor's Export Menu Selection File & Folder Location

Exporting Systems and Exporting Suites are different.  In the Export folder shown above, it shows an exported system named: "Dual Moving Average.tbz."   Exported Systems and Exported Suites share the same folder, but they are very different types of exported file structures.

 

When you export a System from the System Editor, only the system file and the blox files that are attached to the system are included in the exported file.   Exported can be shared with others by placing a copy of the file in the Import folder of the intended  Trading Blox installation.  

 

To add the exported file and its blox module to another Trading Blox installation, click on the main screen File Menu's Import icon in the Folder Group.

Click to Enlarge; Click to Reduce.

System Editor's Export File Goes in Import Folder

Warning:

Be sure that the name of the System and the name of all Blox in the system are unique. We recommend that you use your name, or some other unique identifier, when naming the blox and system modules.

 

If the names used are found during importing they will not conflict with other blox or systems already be Trading Blox installation.

 

When testing an export/import process into the same environment, make a renamed copy of the system and then export, delete the copy, and import. In this way the system name is not duplicated in the same environment.

 

Never change the name of the exported encrypted ".tbz" file once it is created. It is linked to the system name and blox and changing the name will cause the system to not appear.

Print

Creates a text document showing all the blox modules and the blox script sections with script statements.  Text output is sent to the the default text editor.

 

Clicking this button will generate a report that list all the Blox modules contained in the selected system.  In that report each of the modules variables, indicators, parameters and script sections where programming code has been entered will be displayed in a text report that will be displayed in the computer's text editor.

 

Name of the report will be the name of the selected system prefixed with the "Preview".  i.e. "Print Dual Moving Average Entry Exit.txt" will be the name if the Donchian w/Rule Labels System is the selected system.

Click to view entire Print Output

Print Dual Moving Average System

When System Print option is selected a text file is created that shows all the blox and their script information displayed in text file like the example shown in this image.

 

Blox Menu: ^Top

Blox Menu Option:

Menu Description:

System Editor's Blox menu option allows Blox Editor versions to get access to the Blox Editor.

 

 

System Editor Blox Menu Options:

System Editor Blox Menu Options:

 

Selecting a Blox name in the list of available Blox names and right-clicking the mouse will display the same menu near the selected Blox:

System Editor Right-Click Options

System Editor Right-Click Options

 

Add

Selected blox name is added to the selected system name.

Remove

Selected blox name is removed from the selected system name.

Edit

Option: Trading Blox license required.

 

Select a block and click on this Edit menu option to open the selected blox name in the Trading Blox Builder's Blox Editor.  

New

Option: Trading Blox license required.

 

Creates a blox name in the Trading Blox Builder's Blox Editor.

Delete

Selecting the Delete menu open will opens a dialog of the selected blox name to be deleted.

 

Select a block, and click on this button to delete the block from the system and delete the file as well. Blox cannot be delete if they are in a system. Use with caution as blox cannot be recovered once deleted.

 

References

Opens a window showing where the selected blox name is being used.

 

Select a block, and click on this button to see a list of system references. All the systems the block is in will be listed.

Print

Prints the selected Blox Name scripts where statements are located.

 

Prints the block to the printer.

 

Output includes all scripts, variables, indicators, and parameters used the block.

 


Edit Time: 9/20/2017 07:56:26 AM


Topic ID#: 216

 

 

Created with Help & Manual 7 and styled with Premium Pack Version 2.80 © by EC Software