Main Screen File Menu 2016-09-22

Printing: ^Top

Descriptions

File-Menu-Print

After a test report is displayed in the test results area, clicking on this Print button will display Windows' Printer dialog to print the report using the highlighted printer object.

File-Menu-Print-Preview

After a test report is displayed in the test results area, clicking on this Print Preview button will display Windows' Print Preview display screen showing how the test report will look after printing.

File-Menu-Print-Setup

After a test report is displayed in the test results area, clicking on this Printer Setup button will display Windows' Print Setup screen to enable print output adjustments.

Text: ^Top

Descriptions

File-Menu-TextCut

Temporarily Disabled.

File-Menu-TextCopy

When text in blox parameter is highlighted, clicking this button will preserve a copy of the value in Windows' Clipboard area so it can be pasted elsewhere.

File-Menu-TextPaste

When text is in Windows' Clipboard area so it can be pasted in a blox parameter field.

Open Folder: ^Top

Descriptions

FileMenu-OpenFolder-Install ^Top

Install opens to folder name where Trading Blox is installed.

FileMenu-OpenFolder-Orders ^Top

Install opens to folder name where the Order files are located.

FileMenu-OpenFolder-Results ^Top

Install opens to folder name where test Results files are located.

FileMenu-OpenFolder-Importl ^Top

Install opens to folder name where suite Import files are located.

FileMenu-OpenFolder-Datal ^Top

This Data button opens a file dialog at the top level of Data folder where Trading Blox is installed. the Folder that is open will contain the folders for:

Dictionaries, Dividends, Forex, Forex Rates, & Futures

Folder Names:

Purpose:

Auxiliary

Broker Positions, Capital Adds & Draws, IB Fill Files

Dictionaries

Dictionaries, Exchanges, Forex, Futures, Stocks and Currency Codes

Dividends

Stock Dividend Files

Forex

Forex Crossrate Data Files

Forex Rates

Interest Rate files by Currency

Futures

Futures Data Files

Stocks

Stock Data File

FileMenu-OpenFolder-Backup ^Top

Install opens to folder name where Trading Blox the previously backed up files are located.

Install: ^Top

Descriptions

FileMenu-Install-InstallSystemPack ^Top

The system pack can be purchased on the Customer Login section of the website. When purchased, this menu will be enabled.

FileMenu-Install-UpdateBeta ^Top

When this button is enabled, it will check the latest beta license release and will update Trading Blox to the latest point version.  Beta Updates are not the same as the Help Menu's "Check for new version" process that only updates Trading Blox to its latest release version.

Update Data: ^Top

Descriptions

File-Menu-UpdateData-FuturesForex ^Top

Courtesy Data is updated weekly and it is installed with the Trading Blox software. This data is made available to new customers for a period of 90 days, and to trial customers.  Each data button provides an opportunity to update the sample data or the exit with no action.

 

Each button determines the type of data being updated.  Sample data is suitable for testing and developing trading methods for each of the data types, but it will not be current enough to use for active trading signals and position price adjustments.

 

All the buttons in the Update Data section will display an update dialog when a button is clicked.  When the dialog appears it will show this information: "This will close your results windows and download and install new sample data into the Data folder. Would you like to continue?"  

 

 

File-Menu-UpdateData-ETF ^Top

File-Menu-UpdateData-Stocks100 ^Top

File-Menu-UpdateData-NYSE ^Top

File-Menu-UpdateData-NASDAQ ^Top

Global Options: ^Top

Descriptions

FileMenuGlobalOption_Preferences ^Top

This button will open the Trading Blox Preferences Editor Help topic for information about the settings all the software's operation settings.  

 

Topic in this section include:

General Settings for:  

Data Folders and Options   Reporting  

Reporting Settings for:

Reporting General  

Monte Carlo   Single Test Reporting

Small Simulation Reporting

Large Simulation Reporting

Trade Chart

Trade Chart Colors

Trade Details

Blox Editor

Blox Script Colors

 

FileMenuGlobalOption_Theme

Trading Blox theme color has five different options that can be selected when this Theme button is clicked:

FileMenuGlobalOption_ThemeColors FileMenuGlobalOption_ThemeSelected

Application: ^Top

Descriptions

File-Menu-ApplicationXExit

Clicking this button will exit the program.

File-Menu-Application-Backup

This button will display the backup request dialog information"

"This will run the user modifiable backup.bat utility in the background to backup and zip the selected files and folders. The backup will be then date and time stamped and placed in the backups folder. Would you like to continue?"

 

When files are backup, the default process is to store the files in the Backup Folder.

Advanced Users:

It is possible change the backup.bat file, which executes the backup file process, to include other folders, or do other action like copy the blox folder to a Dropbox location or other location.

File-Menu-Application-About

Click this button to show your Trading Blox License and current software version information.

Click to Enlarge, click again to reduce.

Trading Blox License Name and version information.

 


Edit Time: 9/20/2017 07:56:26 AM


Topic ID#: 139

 

 

Created with Help & Manual 7 and styled with Premium Pack Version 2.80 © by EC Software