More CSI problems

Use this forum to discuss data providers like CSI, charting, or other non testing software.
Post Reply
Chris67
Roundtable Knight
Roundtable Knight
Posts: 1046
Joined: Tue Dec 16, 2003 2:12 pm
Location: London

More CSI problems

Post by Chris67 » Tue Feb 08, 2011 2:41 pm

All of my Tokyo markets - TOCOM / TGE seem to have issues in terms of rolling on open interest
I have this new version of CS set up to roll on open interest only
Using Tokyo Platinum as an example
It tells me the contract to be in is April 2011
All of teh volume / OPen interest is in Dec 2011 however
I have queries out with CSI if anyone else having similar issues

marriot
Roundtable Knight
Roundtable Knight
Posts: 347
Joined: Thu Nov 20, 2008 3:02 am

Post by marriot » Wed Feb 09, 2011 2:52 am

Hi Chris,
csi version 2.10.7.111
Tokio Palladium & Tokio Platinum, rolling on open interest, generate forward, roll on second trigger are today on Dec 2011

Chris67
Roundtable Knight
Roundtable Knight
Posts: 1046
Joined: Tue Dec 16, 2003 2:12 pm
Location: London

Post by Chris67 » Wed Feb 09, 2011 4:31 am

Hi Thanks

If set to roll on open interest - there is only 1 trigger ? and thats open interest ? so why are they not rolling on this trigger
Ive been studying this for about 12 hours (sleep trades at a premium round here) - all markets are correct except TOCOM and TGE
Tocom rubber is fine howver
All metals / grains and energies are wrong when set to roll on OI

I rather imagine however I am missing something
Any comments would be warmly appreciated - else when I get an answer from CSI i will post it here such that other people as foolish as me to go with the latest version may get some sleep
C[/img]

AFJ Garner
Roundtable Knight
Roundtable Knight
Posts: 2040
Joined: Fri Apr 25, 2003 3:33 pm
Location: London
Contact:

Post by AFJ Garner » Wed Feb 09, 2011 9:07 am

I don't quite get what your problem is Chris but you should be aware (and see other posts on the Forum) that Tokyo markets trade very differently to those in Europe and the US. Volume usually rolls before open interest and so if you set your rolls on "OI", you will find a lot of the volume has already moved to further out contracts by the time OI switches.

Retail apparently like to trade the far out months. Maybe (?) hedgers / commercial users stay in a contract for longer and thus OI remains high while vol trails off in the near months. Ask your broker or call the exchange.

You can either adopt the Sluggo route (roll on fixed calendar dates) or roll on Vol if you prefer. The problem with rolling on Vol is that the algorithm rolls forward which can cause instability and unwanted month switches. Again, I have pointed this out elsewhere.

You can't really just rely on playing with different baubles and buttons in UA. You need to analyse what is going on and plan accordingly. Yes, it is a time consuming task.

Chris67
Roundtable Knight
Roundtable Knight
Posts: 1046
Joined: Tue Dec 16, 2003 2:12 pm
Location: London

Post by Chris67 » Wed Feb 09, 2011 10:46 am

Thanks Anthony - appreciate your post
I understand what your saying about those Tokyo markets - in this instance I actually think its a glitch with CSI and so do they - They are working on a solution at the moment
As soon as I get it i'll post here for other users of 116
In some way its probably linked in with what you are saying
As soon as I get the glitch sorted out and I know what teh glitch is with CSI - I'm going to look at a differing roll schedule via fixed dates / volumes / IO etc
It is good advice to anyone else reading this post to understand the nature of Tokyo markets howver and the fact they trade so far ahead

Best
C

AFJ Garner
Roundtable Knight
Roundtable Knight
Posts: 2040
Joined: Fri Apr 25, 2003 3:33 pm
Location: London
Contact:

Post by AFJ Garner » Wed Feb 09, 2011 10:59 am

Sorry - generate forward is "good " of course. My muddle - wrong way around. Either way I am seeing no problem. Is this something to do with the UA new build? If so, I have had horrendous problems with updating UA in the past and only do so if I am forced to . I'm still on 2.10.7.102

Chris67
Roundtable Knight
Roundtable Knight
Posts: 1046
Joined: Tue Dec 16, 2003 2:12 pm
Location: London

Post by Chris67 » Wed Feb 09, 2011 12:39 pm

ok there is a glitch on 2.10.7.116
It only looks out 5 contracts >????? why they did that I dont know
Anyway I have the upgrade link if anyone needs it pm me and I'll try and send
c

LeapFrog
Roundtable Knight
Roundtable Knight
Posts: 695
Joined: Mon May 17, 2004 4:18 pm
Location: Boston, MA

Post by LeapFrog » Wed Feb 09, 2011 8:33 pm

I'm also seeing differences between .110 and .116b in the way back adjusting is being determined. Using the date specific method there is no problem, but when using "open interest and volume" the two versions come up with different roll points in the same underlying data - not every contract, but on some.

I called CSI this evening about it and spoke to "Bill". Sent him a bunch of screen shots and he observed the differences and sent my emails on to "the programmers" for further investigation. He also said he spoke to his "boss" who said I was the first one to call about the issue - can that be right?

If no one else has called CSI about this, please do so right away. They are not going to get cracking on this unless they hear from the masses that something is up.

Anyone reading this thread that has the issue, PLEASE CALL CSI TECH SUPPORT RIGHT AWAY, and let them know of the issue.

LeapFrog
Roundtable Knight
Roundtable Knight
Posts: 695
Joined: Mon May 17, 2004 4:18 pm
Location: Boston, MA

Post by LeapFrog » Thu Feb 10, 2011 9:36 am

By way of final update, I contacted CSI about these discrepancies between my version xxx.110 and xxx.116 yesterday afternoon. This morning they have issued a fix and I can confirm that my results are now identical between the two versions. If you previously had downloaded .116, re-download it again and run your benchtesting comparisons between earlier versions and this one. When you download it you will notice it is actually version .116c.

CSI told me:

"...the decision to go with 5 contracts out was due to BR's exceptional activity out in a December 2015 contract, and the number 5 was chosen based on feedback without consideration of the tokyo markets behavior. "

Not sure what that means, but an issue was identified and fixed.

Given I contacted CSI yesterday and the problem is fixed with a new software update this morning, I'd say that is great customer service.

Wisdom
Roundtable Knight
Roundtable Knight
Posts: 112
Joined: Fri Apr 02, 2004 1:40 pm
Location: Jupiter, Florida
Contact:

Post by Wisdom » Thu Feb 10, 2011 10:44 am

Thanks for the update. I brought the BR issue to their attention a week ago. BR was referencing DEC15 as the forward month based on an open interest trigger. I would agree that the data looks like it should now.

If you upgraded to .116 or .116b You might want to check your Milk files to make sure they are checked to Generate Forward. That was another rather odd occurrence I found.

jas-105
Roundtable Knight
Roundtable Knight
Posts: 130
Joined: Sat Aug 02, 2008 2:32 am
Location: London, England.

Post by jas-105 » Thu Feb 24, 2011 5:43 am

I've just upgraded to the UA version 2.10.7.116c myself and somehow I've managed to lose all the current contract months on the order report by using the "Advanced Backadjuster" and now I can't get them back even when refreshing the files with the original backadjuster , anyone else had this problem ? I assume its a rolling problem, will update if solved !

jas-105
Roundtable Knight
Roundtable Knight
Posts: 130
Joined: Sat Aug 02, 2008 2:32 am
Location: London, England.

Post by jas-105 » Tue Mar 01, 2011 2:36 am

I have to shamefully admit to not having done the most basic of checks when setting up a fresh install of UA with TradingBlox, it was the ASCII Field Layout tab in UA that was wrong (it was at default setting). A reminder:

http://www.tradingblox.com/tradingblox/ ... market.htm

Wisdom
Roundtable Knight
Roundtable Knight
Posts: 112
Joined: Fri Apr 02, 2004 1:40 pm
Location: Jupiter, Florida
Contact:

Post by Wisdom » Mon Mar 07, 2011 5:24 pm

BR_ issue returned, for whatever reason. CSI says:

Dear Sir,

a new build is released to fix the issue.
Please use the link below and upgrade to build 117.
http://www.csidata.com/custserv/updates ... pgrade.exe


If your BR_ contract is reporting 201512, you might want to upgrade.

Post Reply