CSI 2.10.7.99 - resets rollover months upon closing...

Use this forum to discuss data providers like CSI, charting, or other non testing software.
Post Reply
LeapFrog
Roundtable Knight
Roundtable Knight
Posts: 695
Joined: Mon May 17, 2004 4:18 pm
Location: Boston, MA

CSI 2.10.7.99 - resets rollover months upon closing...

Post by LeapFrog » Wed Aug 19, 2009 1:16 pm

FYI...

When using fixed date rollovers in this version (the latest one), if you use custom rollover months (like I do in some cases), when closing the edit screen after customizing, CSI throws back in the default settings for rollover months.

You can just see them flash on the screen before the window closes. Does not happen every time though, so to get the months I/you want, you have to click slickly.

I've reported it to CSI Tech Support who are working on it.

LeapFrog
Roundtable Knight
Roundtable Knight
Posts: 695
Joined: Mon May 17, 2004 4:18 pm
Location: Boston, MA

Post by LeapFrog » Fri Aug 21, 2009 10:17 am

I continue to experience problems with this bug and CSI are yet to address the issue.

I was looking for a way to view all my custom selected rollover months out of CSI but there appears no way to do this other than choosing each file and viewing the file properties "Contract Months To Include".

There is a hint. By looking at the Current Contract date (see below) I can check that the front month is accurate. For example, CSI thinks October (V) is an active month for GC2. I happen to prefer only to trade GJMQZ...shown below is the correct front month of December 09.

Here's the interesting part. If I open TB's Futures Dictionary and "Sync" the data for this instrument, I would have expected it to show the months I chose - it doesn't - it shows CSI's default months (includes "V").

Not sure if this is a bug or a feature of TB, but something to be aware of. Or it could be another bug in CSI, or just the way TB and CSI Sync.

Another dog's breakfast though - everything all over the place.
Attachments
GC2 months.PNG
GC2
GC2 months.PNG (7.92 KiB) Viewed 1707 times
GC2 Front Month.PNG
Front Month
GC2 Front Month.PNG (7.72 KiB) Viewed 1707 times

sluggo
Roundtable Knight
Roundtable Knight
Posts: 2986
Joined: Fri Jun 11, 2004 2:50 pm

Post by sluggo » Fri Aug 21, 2009 11:03 am

LeapFrog wrote:I was looking for a way to view all my custom selected rollover months out of CSI but there appears no way to do this other than choosing each file and viewing the file properties "Contract Months To Include"
I'm running Windows XP so I was not forced to upgrade to the latest Vista-inspired release of UA. In the version that I run (CSI UA 2.9), this info is present in the human-readable ASCII text file called "portfile.adm". They use the letter "I" (for inactive) to denote the user has not marked this month with an X and they use the letter "A" (for active) to mean the user did mark this month with an X.

So it is possible to write a little program that reads portfile.adm and tells you which months are chosen, for each instrument in the portfolio.
Attachments
gold1.png
UA file properties (top), portfile.adm (bottom)
gold1.png (45.25 KiB) Viewed 1695 times

LeapFrog
Roundtable Knight
Roundtable Knight
Posts: 695
Joined: Mon May 17, 2004 4:18 pm
Location: Boston, MA

Post by LeapFrog » Fri Aug 21, 2009 12:39 pm

I see that line of code in that machine language file you referred to - it looks like this:

"IAIAIAIAIAIIIA" ValidMonths

and there appears to be a unique record for each instrument in the portfolio. What a mess.

Is there a way to "downgrade" this pesky latest version I have to what I presume is your stable version 2.9 Sluggo?

Clearly it was a mistake to upgrade to their latest version. And I'm running Win XP Pro.

sluggo
Roundtable Knight
Roundtable Knight
Posts: 2986
Joined: Fri Jun 11, 2004 2:50 pm

Post by sluggo » Fri Aug 21, 2009 1:30 pm

Well I did find this on their software downloads page, but I can't tell if the link is alive or dead. Give it a try and/or phone them up and ask for help. Once upon a time they would mail you a CD if you paid a $10 fee, maybe they'll do that for this 2006 release (??)
Attachments
swdl.png
CSI home page -> Software Downloads -> scroll to bottom
swdl.png (22.8 KiB) Viewed 1672 times

LeapFrog
Roundtable Knight
Roundtable Knight
Posts: 695
Joined: Mon May 17, 2004 4:18 pm
Location: Boston, MA

Post by LeapFrog » Mon Aug 24, 2009 1:02 pm

The fix for this just came out. Go to the CSI Support Blox and look for NEWEST BUILD v2.10.7.9x and download and install.

Version will be v2.10.7.100

Post Reply